aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/home/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/home/git.nix')
-rw-r--r--nix/modules/home/git.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/nix/modules/home/git.nix b/nix/modules/home/git.nix
new file mode 100644
index 0000000..84f3b0f
--- /dev/null
+++ b/nix/modules/home/git.nix
@@ -0,0 +1,22 @@
+{ lib, config, ... }:
+{
+ enable = lib.mkDefault config.monorepo.profiles.home.enable;
+ userName = config.vars.fullName;
+ userEmail = config.vars.email;
+ signing = {
+ key = config.vars.gpgKey;
+ signByDefault = true;
+ };
+
+ extraConfig = {
+ init.defaultBranch = "main";
+ };
+
+ aliases = {
+ co = "checkout";
+ c = "commit";
+ a = "add";
+ s = "switch";
+ b = "branch";
+ };
+}