aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/home/git.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-01-16 00:13:06 -0800
committerPreston Pan <ret2pop@gmail.com>2025-01-16 00:13:06 -0800
commit2dff9d2b61244fed49136028d0e0f6ae3ae759cf (patch)
treeb94dabd4a159ed19705c109cd9047a724ddbd4e2 /nix/modules/home/git.nix
parentdd461e48043dabee4694e2b200f4c1d9cfdbc3d9 (diff)
modules about done
Diffstat (limited to 'nix/modules/home/git.nix')
-rw-r--r--nix/modules/home/git.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/nix/modules/home/git.nix b/nix/modules/home/git.nix
new file mode 100644
index 0000000..84f3b0f
--- /dev/null
+++ b/nix/modules/home/git.nix
@@ -0,0 +1,22 @@
+{ lib, config, ... }:
+{
+ enable = lib.mkDefault config.monorepo.profiles.home.enable;
+ userName = config.vars.fullName;
+ userEmail = config.vars.email;
+ signing = {
+ key = config.vars.gpgKey;
+ signByDefault = true;
+ };
+
+ extraConfig = {
+ init.defaultBranch = "main";
+ };
+
+ aliases = {
+ co = "checkout";
+ c = "commit";
+ a = "add";
+ s = "switch";
+ b = "branch";
+ };
+}