aboutsummaryrefslogtreecommitdiff
path: root/nix/disko/vda-simple.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/disko/vda-simple.nix')
-rw-r--r--nix/disko/vda-simple.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/nix/disko/vda-simple.nix b/nix/disko/vda-simple.nix
new file mode 100644
index 0000000..32fa28d
--- /dev/null
+++ b/nix/disko/vda-simple.nix
@@ -0,0 +1,27 @@
+{
+ disko.devices = {
+ disk = {
+ main = {
+ device = "/dev/vda";
+ type = "disk";
+ content = {
+ type = "gpt";
+ partitions = {
+ boot = {
+ size = "1M";
+ type = "EF02";
+ };
+ root = {
+ size = "100%";
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ };
+ };
+ };
+ };
+ };
+ };
+ };
+}