aboutsummaryrefslogtreecommitdiff
path: root/nix/disko/vda-simple.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-02-08 03:19:30 -0800
committerPreston Pan <ret2pop@gmail.com>2025-02-08 03:19:30 -0800
commit504b765606f02b610d74d259ddf2c85292e1f6c0 (patch)
tree49908b9e9064b0f0fc8bf8070e8cf5cdf547e3a6 /nix/disko/vda-simple.nix
parent56faa5e9caf4408c2c4d6df50287c3b1c9e6c1b4 (diff)
add nix-topology; make configuration options less bad; restructure project a bit; add flake system looping
Diffstat (limited to 'nix/disko/vda-simple.nix')
-rw-r--r--nix/disko/vda-simple.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/nix/disko/vda-simple.nix b/nix/disko/vda-simple.nix
new file mode 100644
index 0000000..32fa28d
--- /dev/null
+++ b/nix/disko/vda-simple.nix
@@ -0,0 +1,27 @@
+{
+ disko.devices = {
+ disk = {
+ main = {
+ device = "/dev/vda";
+ type = "disk";
+ content = {
+ type = "gpt";
+ partitions = {
+ boot = {
+ size = "1M";
+ type = "EF02";
+ };
+ root = {
+ size = "100%";
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ };
+ };
+ };
+ };
+ };
+ };
+ };
+}