aboutsummaryrefslogtreecommitdiff
path: root/live/iso.nix
diff options
context:
space:
mode:
Diffstat (limited to 'live/iso.nix')
-rw-r--r--live/iso.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/live/iso.nix b/live/iso.nix
index dd50681..e06f175 100644
--- a/live/iso.nix
+++ b/live/iso.nix
@@ -130,19 +130,16 @@ if [ "$(id -u)" -eq 0 ]; then
echo "ERROR! $(basename "$0") should be run as a regular user"
exit 1
fi
-
if [ ! -d "$HOME/toughnix/" ]; then
cd $HOME
git clone https://git.nullring.xyz/toughnix.git
fi
vim "$HOME/toughnix/desktop/vars.nix"
-vim "$HOME/toughnix/disko/sda-simple.nix"
-
-gum confirm --default=false "🔥 🔥 🔥 WARNING!!!! This will ERASE ALL DATA on the disk. Are you sure you want to continue?"
+vim "$HOME/toughnix/desktop/sda-simple.nix"
sudo nix --experimental-features "nix-command flakes" run github:nix-community/disko/latest -- --mode destroy,format,mount "$HOME/toughnix/disko/sda-simple.nix"
cd /mnt
-sudo nixos-install --flake $HOME/toughnix#continuity-dell
+sudo nixos-install --flake $HOME/toughnix#continuity
'')
];
};