aboutsummaryrefslogtreecommitdiff
path: root/desktop/sda-simple.nix
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/sda-simple.nix')
-rw-r--r--desktop/sda-simple.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/desktop/sda-simple.nix b/desktop/sda-simple.nix
new file mode 100644
index 0000000..a9c1e8f
--- /dev/null
+++ b/desktop/sda-simple.nix
@@ -0,0 +1,37 @@
+# This will install a simple system with a root and boot partition.
+# Make sure to change the entry device entry to the one that you
+# are installing the configuration to.
+{
+ disko.devices = {
+ disk = {
+ my-disk = {
+ # change this entry
+ device = "/dev/sda";
+ type = "disk";
+ content = {
+ type = "gpt";
+ partitions = {
+ ESP = {
+ type = "EF00";
+ size = "500M";
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ mountOptions = [ "umask=0077" ];
+ };
+ };
+ root = {
+ size = "100%";
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ };
+ };
+ };
+ };
+ };
+ };
+ };
+}