aboutsummaryrefslogtreecommitdiff
path: root/desktop/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/home.nix')
-rw-r--r--desktop/home.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/desktop/home.nix b/desktop/home.nix
index f649145..ddaf573 100644
--- a/desktop/home.nix
+++ b/desktop/home.nix
@@ -3,6 +3,19 @@ let
vars = import ./vars.nix;
in
{
+ sops = {
+ defaultSopsFile = ../secrets/secrets.yaml;
+ age = {
+ keyFile = "${config.home.homeDirectory}/.ssh/keys.txt";
+ };
+ secrets.mail = {
+ format = "yaml";
+ path = "${config.sops.defaultSymlinkPath}/mail";
+ };
+ defaultSymlinkPath = "/run/user/1000/secrets";
+ defaultSecretsMountPoint = "/run/user/1000/secrets.d";
+ };
+
home = {
activation.startup-files = lib.hm.dag.entryAfter [ "installPackages" ] ''
if [ ! -d "${config.home.homeDirectory}/org/website/" ]; then
@@ -45,6 +58,7 @@ in
packages = with pkgs; [
# kicad
+ age
acpilight
alsa-utils
autobuild