aboutsummaryrefslogtreecommitdiff
path: root/desktop/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/configuration.nix')
-rw-r--r--desktop/configuration.nix22
1 files changed, 2 insertions, 20 deletions
diff --git a/desktop/configuration.nix b/desktop/configuration.nix
index 79bc5fa..aa5290e 100644
--- a/desktop/configuration.nix
+++ b/desktop/configuration.nix
@@ -5,9 +5,7 @@ in
{
imports = [];
- hardware = {
- enableRedistributableFirmware = true;
- };
+ hardware.enableAllFirmware = true;
documentation = {
enable = true;
@@ -23,14 +21,6 @@ in
'';
};
};
- # environment = {
- # memoryAllocator.provider = "scudo";
- # variables.SCUDO_OPTIONS = "ZeroContents=1";
- # };
-
- # environment = {
- # memoryAllocator.provider = "graphene-hardened-light";
- # };
systemd = {
coredump.enable = false;
@@ -359,15 +349,7 @@ in
auditd.enable = true;
audit.enable = true;
chromiumSuidSandbox.enable = true;
- sudo.enable = false;
- doas = {
- enable = true;
- extraRules = [{
- users = [ vars.userName ];
- keepEnv = true;
- persist = true;
- }];
- };
+ sudo.enable = true;
};
xdg.portal = {