diff options
author | Preston Pan <preston@nullring.xyz> | 2024-03-08 12:49:42 -0800 |
---|---|---|
committer | Preston Pan <preston@nullring.xyz> | 2024-03-08 12:49:42 -0800 |
commit | bd4d15f313b7af2a61f1ecd3f4de36105f07b4fc (patch) | |
tree | 18fbe757f97dbe43cfe83f321de0d68f829ac3b0 /flake.nix | |
parent | 53e1f570b2cd2df3f2c7994af93e09078267c77d (diff) |
make wallpaper a flake
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 23 |
1 files changed, 13 insertions, 10 deletions
@@ -12,30 +12,33 @@ url = "github:nix-community/disko"; inputs.nixpkgs.follows = "nixpkgs"; }; + wallpapers.url = "github:ret2pop/wallpapers"; }; - outputs = inputs@{ nixpkgs, home-manager, nur, disko, ... }: { + outputs = { self, nixpkgs, home-manager, nur, disko, wallpapers, ... }@attrs: { nixosConfigurations = { continuity = nixpkgs.lib.nixosSystem { system = "x86_64-linux"; + specialArgs = attrs; modules = [ { nixpkgs.overlays = [ nur.overlay ]; } ({ pkgs, ... }: - let - nur-no-pkgs = import nur { - inherit pkgs; - nurpkgs = import nixpkgs { system = "x86_64-linux"; }; - }; - in { - imports = [ ]; - }) + let + nur-no-pkgs = import nur { + inherit pkgs; + nurpkgs = import nixpkgs { system = "x86_64-linux"; }; + }; + in + { + imports = [ ]; + }) ./configuration.nix disko.nixosModules.disko home-manager.nixosModules.home-manager { home-manager.useGlobalPkgs = true; + home-manager.extraSpecialArgs = attrs; home-manager.useUserPackages = true; - home-manager.users.preston = import ./home.nix; } ]; |