aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-01-09 14:49:49 -0800
committerPreston Pan <ret2pop@gmail.com>2025-01-09 14:49:49 -0800
commita410a402a5dc5c68208ab8d6610fade60c8639c0 (patch)
treead1a15f899ba2ca397c0919f74e2c3634502d6c9 /flake.nix
parent87ce8be7319fa8612a7edcb9261272688ab099bb (diff)
use disko instead of rolling my own scripts and fixes
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index 5595eb0..8ac9000 100644
--- a/flake.nix
+++ b/flake.nix
@@ -34,7 +34,7 @@
({pkgs, modulesPath, ...}: {
imports = [(modulesPath + "/installer/cd-dvd/installation-cd-minimal.nix")];
})
- ./iso.nix
+ ./live/iso.nix
];
};
@@ -54,16 +54,16 @@
imports = [ ];
})
lanzaboote.nixosModules.lanzaboote
- ./configuration.nix
+ ./desktop/configuration.nix
disko.nixosModules.disko
- ./disk-config.nix
+ ./sda/disk-config.nix
home-manager.nixosModules.home-manager
{
home-manager = {
useGlobalPkgs = true;
extraSpecialArgs = attrs;
useUserPackages = true;
- users.preston = import ./home.nix;
+ users.preston = import ./desktop/home.nix;
};
}
];