diff options
author | Preston Pan <preston@nullring.xyz> | 2024-03-07 00:26:39 -0800 |
---|---|---|
committer | Preston Pan <preston@nullring.xyz> | 2024-03-07 00:26:39 -0800 |
commit | a08061e975344f21805d115e01929566a36c8d05 (patch) | |
tree | 3a3dd2abab1af784ec90f8bd8b28188cc428440b /flake.nix | |
parent | 9572f04e52b1417880c00d52143cb3d5f7c6888c (diff) |
add disko/nixos-anywhere configuration
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 11 |
1 files changed, 6 insertions, 5 deletions
@@ -5,15 +5,16 @@ nixpkgs.url = "github:nixos/nixpkgs/nixos-23.11"; home-manager = { url = "github:nix-community/home-manager/release-23.11"; - # Here, `inputs.nixpkgs` of home-manager is kept consistent with - # the `inputs.nixpkgs` of the current flake, - # to avoid problems caused by different versions of nixpkgs. inputs.nixpkgs.follows = "nixpkgs"; }; nur.url = "github:nix-community/NUR"; + disko = { + url = "github:nix-community/disko"; + inputs.nixpkgs.follows = "nixpkgs"; + }; }; - outputs = inputs@{ nixpkgs, home-manager, nur, ... }: { + outputs = inputs@{ nixpkgs, home-manager, nur, disko, ... }: { nixosConfigurations = { continuity = nixpkgs.lib.nixosSystem { system = "x86_64-linux"; @@ -29,7 +30,7 @@ imports = [ ]; }) ./configuration.nix - + disko.nixosModules.disko home-manager.nixosModules.home-manager { home-manager.useGlobalPkgs = true; |