diff options
author | Preston Pan <preston@nullring.xyz> | 2024-03-27 10:14:27 -0700 |
---|---|---|
committer | Preston Pan <preston@nullring.xyz> | 2024-03-27 10:14:27 -0700 |
commit | 3278e02f9c08f91d423a611d28d2eec2f1999ba6 (patch) | |
tree | 021374b0d41e2d4ac25a78c57588fac8ae8e8620 /flake.nix | |
parent | b0468f02e5a7ef82749af3d76fd9c3d769cf4228 (diff) |
some changes
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 27 |
1 files changed, 27 insertions, 0 deletions
@@ -19,6 +19,33 @@ outputs = { self, nixpkgs, home-manager, nur, disko, wallpapers, sops-nix, scripts, ... }@attrs: { nixosConfigurations = { + live = nixpkgs.lib.nixosSystem { + system = "x86_64-linux"; + specialArgs = attrs; + modules = [ + { nixpkgs.overlays = [ nur.overlay ]; } + ({ pkgs, ... }: + let + nur-no-pkgs = import nur { + inherit pkgs; + nurpkgs = import nixpkgs { system = "x86_64-linux"; }; + }; + in + { + imports = [ ]; + }) + (nixpkgs + "/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix") + ./configuration.nix + disko.nixosModules.disko + home-manager.nixosModules.home-manager + { + home-manager.useGlobalPkgs = true; + home-manager.extraSpecialArgs = attrs; + home-manager.useUserPackages = true; + home-manager.users.preston = import ./home.nix; + } + ]; + }; continuity = nixpkgs.lib.nixosSystem { system = "x86_64-linux"; specialArgs = attrs; |