aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-01-08 23:55:09 -0800
committerPreston Pan <ret2pop@gmail.com>2025-01-08 23:55:09 -0800
commit2b0e8f4306b8580f54531da1b4e6e5c1e891e02b (patch)
tree431ecb1ac3780f1b629bcc411a5fa3c13a539c9b /flake.nix
parentd8900b3f01bf98911516d39c2c96549485f54577 (diff)
iso.nix
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix29
1 files changed, 5 insertions, 24 deletions
diff --git a/flake.nix b/flake.nix
index 6ce5656..5595eb0 100644
--- a/flake.nix
+++ b/flake.nix
@@ -30,31 +30,11 @@
nixosConfigurations = {
live = nixpkgs.lib.nixosSystem {
system = "x86_64-linux";
- specialArgs = attrs;
modules = [
- { nixpkgs.overlays = [ nur.overlays.default ]; }
- ({ pkgs, ... }:
- let
- nur-no-pkgs = import nur {
- inherit pkgs;
- nurpkgs = import nixpkgs { system = "x86_64-linux"; };
- };
- in
- {
- imports = [ ];
- })
- (nixpkgs + "/nixos/modules/installer/cd-dvd/installation-cd-minimal.nix")
- ./configuration.nix
- disko.nixosModules.disko
- home-manager.nixosModules.home-manager
- {
- home-manager = {
- useGlobalPkgs = true;
- extraSpecialArgs = attrs;
- useUserPackages = true;
- users.preston = import ./home.nix;
- };
- }
+ ({pkgs, modulesPath, ...}: {
+ imports = [(modulesPath + "/installer/cd-dvd/installation-cd-minimal.nix")];
+ })
+ ./iso.nix
];
};
@@ -76,6 +56,7 @@
lanzaboote.nixosModules.lanzaboote
./configuration.nix
disko.nixosModules.disko
+ ./disk-config.nix
home-manager.nixosModules.home-manager
{
home-manager = {