aboutsummaryrefslogtreecommitdiff
path: root/nix/topology/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/topology/default.nix')
-rw-r--r--nix/topology/default.nix59
1 files changed, 59 insertions, 0 deletions
diff --git a/nix/topology/default.nix b/nix/topology/default.nix
new file mode 100644
index 0000000..ce0b3a4
--- /dev/null
+++ b/nix/topology/default.nix
@@ -0,0 +1,59 @@
+{ config, ... }:
+let
+ inherit
+ (config.lib.topology);
+in
+{
+ # Connect node1.lan -> node2.wan
+ nodes = {
+ spontaneity = {
+ interfaces.wan.network = "remote";
+ };
+
+ installer = {
+ interfaces.lan.network = "home";
+ };
+
+ affinity = {
+ interfaces.lan = {
+ network = "home";
+ physicalConnections = [
+ {
+ node = "spontaneity";
+ interface = "wan";
+ }
+ {
+ node = "installer";
+ interface = "lan";
+ }
+ ];
+ };
+ };
+ continuity = {
+ interfaces.lan = {
+ network = "home";
+ physicalConnections = [
+ {
+ node = "spontaneity";
+ interface = "wan";
+ }
+ {
+ node = "affinity";
+ interface = "lan";
+ }
+ ];
+ };
+ };
+ };
+
+ networks = {
+ home = {
+ name = "Home Network";
+ cidrv4 = "192.168.1.1/24";
+ };
+ remote = {
+ name = "Remote Network";
+ cidrv4 = "144.202.27.169/32";
+ };
+ };
+}