aboutsummaryrefslogtreecommitdiff
path: root/nix/systems/desktop/sda-simple.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/systems/desktop/sda-simple.nix')
-rw-r--r--nix/systems/desktop/sda-simple.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/nix/systems/desktop/sda-simple.nix b/nix/systems/desktop/sda-simple.nix
new file mode 100644
index 0000000..86263dd
--- /dev/null
+++ b/nix/systems/desktop/sda-simple.nix
@@ -0,0 +1,39 @@
+# This will install a simple system with a root and boot partition.
+# Make sure to change the entry device entry to the one that you
+# are installing the configuration to.
+{
+ disko.devices = {
+ disk = {
+ my-disk = {
+ # change this entry
+ device = "/dev/sda";
+ type = "disk";
+ content = {
+ type = "gpt";
+ partitions = {
+ ESP = {
+ type = "EF00";
+ size = "500M";
+ priority = 1;
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ mountOptions = [ "umask=0077" ];
+ };
+ };
+ root = {
+ size = "100%";
+ priority = 2;
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ };
+ };
+ };
+ };
+ };
+ };
+ };
+}