aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/vars.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/vars.nix')
-rw-r--r--nix/modules/vars.nix91
1 files changed, 50 insertions, 41 deletions
diff --git a/nix/modules/vars.nix b/nix/modules/vars.nix
index ed545fd..c2c10ea 100644
--- a/nix/modules/vars.nix
+++ b/nix/modules/vars.nix
@@ -1,50 +1,59 @@
{ lib, ... }:
{
- hostName = lib.mkOption {
- type = lib.types.str;
- default = "continuity";
- example = "hostname";
- description = "system hostname";
- };
+ options.monorepo.vars = {
+ hostName = lib.mkOption {
+ type = lib.types.str;
+ default = "continuity";
+ example = "hostname";
+ description = "system hostname";
+ };
- userName = lib.mkOption {
- type = lib.types.str;
- default = "preston";
- example = "myUser";
- description = "system username";
- };
+ userName = lib.mkOption {
+ type = lib.types.str;
+ default = "preston";
+ example = "myUser";
+ description = "system username";
+ };
- fullName = lib.mkOption {
- type = lib.types.str;
- default = "Preston Pan";
- example = "John Doe";
- description = "Full Name";
- };
+ fullName = lib.mkOption {
+ type = lib.types.str;
+ default = "Preston Pan";
+ example = "John Doe";
+ description = "Full Name";
+ };
- gpgKey = lib.mkOption {
- type = lib.types.str;
- default = "AEC273BF75B6F54D81343A1AC1FE6CED393AE6C1";
- example = "1234567890ABCDEF...";
- description = "GPG key fingerprint";
- };
+ gpgKey = lib.mkOption {
+ type = lib.types.str;
+ default = "AEC273BF75B6F54D81343A1AC1FE6CED393AE6C1";
+ example = "1234567890ABCDEF...";
+ description = "GPG key fingerprint";
+ };
- remoteHost = lib.mkOption {
- type = lib.types.str;
- default = "nullring.xyz";
- example = "example.com";
- description = "Address to push to and pull from for website and git repos";
- };
+ remoteHost = lib.mkOption {
+ type = lib.types.str;
+ default = "nullring.xyz";
+ example = "example.com";
+ description = "Address to push to and pull from for website and git repos";
+ };
- timeZone = lib.mkOption {
- type = lib.types.str;
- default = "America/Vancouver";
- example = "America/Chicago";
- description = "Linux timezone";
- };
- disk = lib.mkOption {
- type = lib.types.str;
- default = "/dev/sda";
- example = "/dev/nvme0n1";
- description = "Disk to install NixOS to";
+ timeZone = lib.mkOption {
+ type = lib.types.str;
+ default = "America/Vancouver";
+ example = "America/Chicago";
+ description = "Linux timezone";
+ };
+
+ monitors = lib.mkOption {
+ type = lib.types.listOf lib.types.str;
+ default = [
+ "HDMI-A-1"
+ "eDP-1"
+ "DP-2"
+ "DP-3"
+ "LVDS-1"
+ ];
+ example = [];
+ description = "Monitors that waybar will use";
+ };
};
}