aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/ssh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/ssh.nix')
-rw-r--r--nix/modules/ssh.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/nix/modules/ssh.nix b/nix/modules/ssh.nix
new file mode 100644
index 0000000..6083393
--- /dev/null
+++ b/nix/modules/ssh.nix
@@ -0,0 +1,10 @@
+{ config, ... }:
+{
+ enable = true;
+ settings = {
+ PasswordAuthentication = true;
+ AllowUsers = [ config.vars.userName ];
+ PermitRootLogin = "no";
+ KbdInteractiveAuthentication = false;
+ };
+}