aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/sda-simple.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/sda-simple.nix')
-rw-r--r--nix/modules/sda-simple.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/nix/modules/sda-simple.nix b/nix/modules/sda-simple.nix
new file mode 100644
index 0000000..f4d6e0e
--- /dev/null
+++ b/nix/modules/sda-simple.nix
@@ -0,0 +1,36 @@
+{ config, ... }:
+{
+ disko.devices = {
+ disk = {
+ my-disk = {
+ device = config.monorepo.vars.disk;
+ type = "disk";
+ content = {
+ type = "gpt";
+ partitions = {
+ ESP = {
+ type = "EF00";
+ size = "500M";
+ priority = 1;
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ mountOptions = [ "umask=0077" ];
+ };
+ };
+ root = {
+ size = "100%";
+ priority = 2;
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ };
+ };
+ };
+ };
+ };
+ };
+ };
+}