aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/sda-simple.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-01-16 00:13:06 -0800
committerPreston Pan <ret2pop@gmail.com>2025-01-16 00:13:06 -0800
commit2dff9d2b61244fed49136028d0e0f6ae3ae759cf (patch)
treeb94dabd4a159ed19705c109cd9047a724ddbd4e2 /nix/modules/sda-simple.nix
parentdd461e48043dabee4694e2b200f4c1d9cfdbc3d9 (diff)
modules about done
Diffstat (limited to 'nix/modules/sda-simple.nix')
-rw-r--r--nix/modules/sda-simple.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/nix/modules/sda-simple.nix b/nix/modules/sda-simple.nix
new file mode 100644
index 0000000..f4d6e0e
--- /dev/null
+++ b/nix/modules/sda-simple.nix
@@ -0,0 +1,36 @@
+{ config, ... }:
+{
+ disko.devices = {
+ disk = {
+ my-disk = {
+ device = config.monorepo.vars.disk;
+ type = "disk";
+ content = {
+ type = "gpt";
+ partitions = {
+ ESP = {
+ type = "EF00";
+ size = "500M";
+ priority = 1;
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ mountOptions = [ "umask=0077" ];
+ };
+ };
+ root = {
+ size = "100%";
+ priority = 2;
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ };
+ };
+ };
+ };
+ };
+ };
+ };
+}