aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/home/user.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/home/user.nix')
-rw-r--r--nix/modules/home/user.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/nix/modules/home/user.nix b/nix/modules/home/user.nix
index 882041b..85b6a70 100644
--- a/nix/modules/home/user.nix
+++ b/nix/modules/home/user.nix
@@ -62,12 +62,17 @@
pfetch
libnotify
htop
- (writeShellScriptBin "install_vps"
+ (writeShellScriptBin "remote-build"
''
#!/bin/bash
-nix run github:nix-community/nixos-anywhere -- --generate-hardware-config nixos-generate-config ./systems/spontaneity/hardware-configuration.nix --flake .#spontaneity --target-host "$1"
- ''
+nixos-rebuild --target-host "$1" switch --flake .#spontaneity
+''
)
+ (writeShellScriptBin "install-vps"
+ ''
+#!/bin/bash
+nix run github:nix-community/nixos-anywhere -- --generate-hardware-config nixos-generate-config ./systems/spontaneity/hardware-configuration.nix --flake .#spontaneity --target-host "$1"
+ '')
] else [
pfetch