aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/home/user.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-02-08 03:19:30 -0800
committerPreston Pan <ret2pop@gmail.com>2025-02-08 03:19:30 -0800
commit504b765606f02b610d74d259ddf2c85292e1f6c0 (patch)
tree49908b9e9064b0f0fc8bf8070e8cf5cdf547e3a6 /nix/modules/home/user.nix
parent56faa5e9caf4408c2c4d6df50287c3b1c9e6c1b4 (diff)
add nix-topology; make configuration options less bad; restructure project a bit; add flake system looping
Diffstat (limited to 'nix/modules/home/user.nix')
-rw-r--r--nix/modules/home/user.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/nix/modules/home/user.nix b/nix/modules/home/user.nix
index 882041b..85b6a70 100644
--- a/nix/modules/home/user.nix
+++ b/nix/modules/home/user.nix
@@ -62,12 +62,17 @@
pfetch
libnotify
htop
- (writeShellScriptBin "install_vps"
+ (writeShellScriptBin "remote-build"
''
#!/bin/bash
-nix run github:nix-community/nixos-anywhere -- --generate-hardware-config nixos-generate-config ./systems/spontaneity/hardware-configuration.nix --flake .#spontaneity --target-host "$1"
- ''
+nixos-rebuild --target-host "$1" switch --flake .#spontaneity
+''
)
+ (writeShellScriptBin "install-vps"
+ ''
+#!/bin/bash
+nix run github:nix-community/nixos-anywhere -- --generate-hardware-config nixos-generate-config ./systems/spontaneity/hardware-configuration.nix --flake .#spontaneity --target-host "$1"
+ '')
] else [
pfetch