aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/cuda.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/cuda.nix')
-rw-r--r--nix/modules/cuda.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nix/modules/cuda.nix b/nix/modules/cuda.nix
index dd5846b..d5d9b7c 100644
--- a/nix/modules/cuda.nix
+++ b/nix/modules/cuda.nix
@@ -1,9 +1,9 @@
{ config, lib, pkgs, ... }:
{
- environment.systemPackages = with pkgs; [
+ environment.systemPackages = (if config.monorepo.profiles.cuda.enable then with pkgs; [
cudatoolkit
cudaPackages.cudnn
cudaPackages.libcublas
linuxPackages.nvidia_x11
- ];
+ ] else []);
}