aboutsummaryrefslogtreecommitdiff
path: root/nix/systems/desktop/vars.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-01-13 22:11:02 -0800
committerPreston Pan <ret2pop@gmail.com>2025-01-13 22:11:02 -0800
commitdd461e48043dabee4694e2b200f4c1d9cfdbc3d9 (patch)
treebc6c481be908e92e52d7828caf17365d00f5e7b7 /nix/systems/desktop/vars.nix
parentd878a0353ba8cec87df4f79d59864c92b1ea4cea (diff)
merge these two repos into one
Diffstat (limited to 'nix/systems/desktop/vars.nix')
-rw-r--r--nix/systems/desktop/vars.nix54
1 files changed, 54 insertions, 0 deletions
diff --git a/nix/systems/desktop/vars.nix b/nix/systems/desktop/vars.nix
new file mode 100644
index 0000000..eb0b305
--- /dev/null
+++ b/nix/systems/desktop/vars.nix
@@ -0,0 +1,54 @@
+# Change the following variables
+{
+ # set your host name.
+ hostName = "continuity";
+
+ # username used for unix username as well as msmtp configuration name.
+ userName = "preston";
+
+ # your full name
+ fullName = "Preston Pan";
+
+ # Create a new gpg key for this system or import your keys from another system
+ gpgKey = "AEC273BF75B6F54D81343A1AC1FE6CED393AE6C1";
+
+ # Used for referencing the remote host in config. This mostly shouldn't matter if you are not
+ # using my website.
+ remoteHost = "nullring.xyz";
+
+ # email used for `From` and also as your login email.
+ email = "ret2pop@gmail.com";
+
+ # IMAPS server. Must be encrypted.
+ imapsServer = "imap.gmail.com";
+
+ # SMTPS server. Must be encrypted.
+ smtpsServer = "smtp.gmail.com";
+
+ # Change to your timezone
+ timeZone = "America/Vancouver";
+
+ # After rebooting, use the command `hyprctl monitors` in order to check which monitor
+ # you are using. This is so that waybar knows which monitors to appear in.
+ monitors = [
+ "HDMI-A-1"
+ "eDP-1"
+ "DP-2"
+ "DP-3"
+ "LVDS-1"
+ ];
+
+ # enable video drivers based on your system.
+ # Example:
+ # videoDrivers = [
+ # "nvidia"
+ # "amdgpu"
+ # ]
+ videoDrivers = [
+ ];
+
+ # use false if this is your first install of continuity.
+ # See https://github.com/nix-community/lanzaboote/blob/master/docs/QUICK_START.md
+ # for more information.
+ secureBoot = false;
+}