aboutsummaryrefslogtreecommitdiff
path: root/nix/systems/desktop/home.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-01-13 22:11:02 -0800
committerPreston Pan <ret2pop@gmail.com>2025-01-13 22:11:02 -0800
commitdd461e48043dabee4694e2b200f4c1d9cfdbc3d9 (patch)
treebc6c481be908e92e52d7828caf17365d00f5e7b7 /nix/systems/desktop/home.nix
parentd878a0353ba8cec87df4f79d59864c92b1ea4cea (diff)
merge these two repos into one
Diffstat (limited to 'nix/systems/desktop/home.nix')
-rw-r--r--nix/systems/desktop/home.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/nix/systems/desktop/home.nix b/nix/systems/desktop/home.nix
new file mode 100644
index 0000000..166bd16
--- /dev/null
+++ b/nix/systems/desktop/home.nix
@@ -0,0 +1,14 @@
+{ sops-nix, ... }:
+let
+ vars = import ./vars.nix;
+in
+{
+ home-manager = {
+ sharedModules = [
+ sops-nix.homeManagerModules.sops
+ ];
+ useGlobalPkgs = true;
+ useUserPackages = true;
+ users."${vars.userName}" = ./user.nix;
+ };
+}