aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/nvme-simple.nix
diff options
context:
space:
mode:
authorPreston Pan <preston@nullring.xyz>2025-01-29 14:11:40 -0800
committerPreston Pan <preston@nullring.xyz>2025-01-29 14:11:40 -0800
commit7083deb773b9c12ef56da6a934f9f0daca95d8ba (patch)
tree5c3673c34cc7fb71c8a7e87a22081890ab59f538 /nix/modules/nvme-simple.nix
parent2a4a4e2c42257bb25789ec3be6bc5a88f0eab7b5 (diff)
add affinity system
Diffstat (limited to 'nix/modules/nvme-simple.nix')
-rw-r--r--nix/modules/nvme-simple.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/nix/modules/nvme-simple.nix b/nix/modules/nvme-simple.nix
new file mode 100644
index 0000000..665c17e
--- /dev/null
+++ b/nix/modules/nvme-simple.nix
@@ -0,0 +1,35 @@
+{
+ disko.devices = {
+ disk = {
+ my-disk = {
+ device = "/dev/nvme0n1";
+ type = "disk";
+ content = {
+ type = "gpt";
+ partitions = {
+ ESP = {
+ type = "EF00";
+ size = "500M";
+ priority = 1;
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ mountOptions = [ "umask=0077" ];
+ };
+ };
+ root = {
+ size = "100%";
+ priority = 2;
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ };
+ };
+ };
+ };
+ };
+ };
+ };
+}