aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/home/wofi.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-01-16 02:11:26 -0800
committerPreston Pan <ret2pop@gmail.com>2025-01-16 02:11:26 -0800
commit1a3486d77574c06b395ab6cda41084f5ed24a3f4 (patch)
tree69d1051bd14a0c3cb374f84a8c06cb655eba509b /nix/modules/home/wofi.nix
parent2dff9d2b61244fed49136028d0e0f6ae3ae759cf (diff)
modularized nix configuration; builds correctly
Diffstat (limited to 'nix/modules/home/wofi.nix')
-rw-r--r--nix/modules/home/wofi.nix38
1 files changed, 20 insertions, 18 deletions
diff --git a/nix/modules/home/wofi.nix b/nix/modules/home/wofi.nix
index d2b1e53..f6c4179 100644
--- a/nix/modules/home/wofi.nix
+++ b/nix/modules/home/wofi.nix
@@ -1,23 +1,24 @@
{ lib, config, ... }:
{
- enable = lib.mkDefault config.monorepo.profiles.home.enable;
- settings = {
- location = "bottom-right";
- allow_markup = true;
- show = "drun";
- width = 750;
- height = 400;
- always_parse_args = true;
- show_all = false;
- term = "kitty";
- hide_scroll = true;
- print_command = true;
- insensitive = true;
- prompt = "Run what, Commander?";
- columns = 2;
- };
-
- style = ''
+ programs.wofi = {
+ enable = true;
+ settings = {
+ location = "bottom-right";
+ allow_markup = true;
+ show = "drun";
+ width = 750;
+ height = 400;
+ always_parse_args = true;
+ show_all = false;
+ term = "kitty";
+ hide_scroll = true;
+ print_command = true;
+ insensitive = true;
+ prompt = "Run what, Commander?";
+ columns = 2;
+ };
+
+ style = ''
@define-color rosewater #f5e0dc;
@define-color rosewater-rgb rgb(245, 224, 220);
@define-color flamingo #f2cdcd;
@@ -183,4 +184,5 @@
background-color: @lavender!important;
}
'';
+ };
}