aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/home/user.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-02-13 00:29:25 -0800
committerPreston Pan <ret2pop@gmail.com>2025-02-13 00:29:25 -0800
commit5e02cdc7ed82ac10375cacfca6920f20f5729059 (patch)
tree53466f89296545a8df26fbc2e30a37a395a0613a /nix/modules/home/user.nix
parentf10285de4d0b5c69d026e948a9d9d7278a2ffb64 (diff)
Add vps capabilities
Diffstat (limited to 'nix/modules/home/user.nix')
-rw-r--r--nix/modules/home/user.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nix/modules/home/user.nix b/nix/modules/home/user.nix
index 85b6a70..7872d53 100644
--- a/nix/modules/home/user.nix
+++ b/nix/modules/home/user.nix
@@ -65,7 +65,8 @@
(writeShellScriptBin "remote-build"
''
#!/bin/bash
-nixos-rebuild --target-host "$1" switch --flake .#spontaneity
+cd ~/monorepo/nix
+nixos-rebuild --use-remote-sudo --target-host "$1" switch --flake .#spontaneity
''
)
(writeShellScriptBin "install-vps"