aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/home/gammastep.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-01-16 02:11:26 -0800
committerPreston Pan <ret2pop@gmail.com>2025-01-16 02:11:26 -0800
commit1a3486d77574c06b395ab6cda41084f5ed24a3f4 (patch)
tree69d1051bd14a0c3cb374f84a8c06cb655eba509b /nix/modules/home/gammastep.nix
parent2dff9d2b61244fed49136028d0e0f6ae3ae759cf (diff)
modularized nix configuration; builds correctly
Diffstat (limited to 'nix/modules/home/gammastep.nix')
-rw-r--r--nix/modules/home/gammastep.nix26
1 files changed, 14 insertions, 12 deletions
diff --git a/nix/modules/home/gammastep.nix b/nix/modules/home/gammastep.nix
index 97f7660..ae9d111 100644
--- a/nix/modules/home/gammastep.nix
+++ b/nix/modules/home/gammastep.nix
@@ -1,18 +1,20 @@
{ lib, config, ... }:
{
- enable = lib.mkDefault config.monorepo.profiles.home.enable;
- provider = "manual";
- latitude = 49.282730;
- longitude = -123.120735;
-
- temperature = {
- day = 5000;
- night = 3000;
- };
+ services.gammastep = {
+ enable = true;
+ provider = "manual";
+ latitude = 49.282730;
+ longitude = -123.120735;
+
+ temperature = {
+ day = 5000;
+ night = 3000;
+ };
- settings = {
- general = {
- adjustment-method = "wayland";
+ settings = {
+ general = {
+ adjustment-method = "wayland";
+ };
};
};
}