aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/home/default.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-02-08 03:19:30 -0800
committerPreston Pan <ret2pop@gmail.com>2025-02-08 03:19:30 -0800
commit504b765606f02b610d74d259ddf2c85292e1f6c0 (patch)
tree49908b9e9064b0f0fc8bf8070e8cf5cdf547e3a6 /nix/modules/home/default.nix
parent56faa5e9caf4408c2c4d6df50287c3b1c9e6c1b4 (diff)
add nix-topology; make configuration options less bad; restructure project a bit; add flake system looping
Diffstat (limited to 'nix/modules/home/default.nix')
-rw-r--r--nix/modules/home/default.nix17
1 files changed, 1 insertions, 16 deletions
diff --git a/nix/modules/home/default.nix b/nix/modules/home/default.nix
index 45b0890..13966da 100644
--- a/nix/modules/home/default.nix
+++ b/nix/modules/home/default.nix
@@ -42,23 +42,8 @@
music.enable = lib.mkEnableOption "Enables mpd";
workstation.enable = lib.mkEnableOption "Enables workstation packages (music production and others)";
cuda.enable = lib.mkEnableOption "Enables CUDA user package builds";
+ hyprland.enable = lib.mkEnableOption "Enables hyprland";
- hyprland = {
- enable = lib.mkEnableOption "Enables hyprland";
- monitors = lib.mkOption {
- type = lib.types.listOf lib.types.str;
- default = [
- "HDMI-A-1"
- "eDP-1"
- "DP-2"
- "DP-3"
- "LVDS-1"
- "DP-4"
- ];
- example = [];
- description = "Hyprland monitors";
- };
- };
email = {
email = lib.mkOption {
type = lib.types.str;