aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/git-daemon.nix
diff options
context:
space:
mode:
authorPreston Pan <preston@nullring.xyz>2025-01-29 14:11:40 -0800
committerPreston Pan <preston@nullring.xyz>2025-01-29 14:11:40 -0800
commit7083deb773b9c12ef56da6a934f9f0daca95d8ba (patch)
tree5c3673c34cc7fb71c8a7e87a22081890ab59f538 /nix/modules/git-daemon.nix
parent2a4a4e2c42257bb25789ec3be6bc5a88f0eab7b5 (diff)
add affinity system
Diffstat (limited to 'nix/modules/git-daemon.nix')
-rw-r--r--nix/modules/git-daemon.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/nix/modules/git-daemon.nix b/nix/modules/git-daemon.nix
new file mode 100644
index 0000000..e71356e
--- /dev/null
+++ b/nix/modules/git-daemon.nix
@@ -0,0 +1,9 @@
+{ config, lib, ... }:
+{
+ services.gitDaemon = {
+ enable = lib.mkDefault config.monorepo.profiles.server.enable;
+ exportAll = true;
+ listenAddress = "0.0.0.0";
+ basePath = "/srv/git";
+ };
+}