aboutsummaryrefslogtreecommitdiff
path: root/nix/flake.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-02-11 04:06:11 -0800
committerPreston Pan <ret2pop@gmail.com>2025-02-11 04:06:11 -0800
commitf10285de4d0b5c69d026e948a9d9d7278a2ffb64 (patch)
treedc1138970d2dae203aaeede6e036c637fbf3d2a6 /nix/flake.nix
parentbe4a011bac9b2212d81b572c3bb9b80f8c326ab0 (diff)
add resume
Diffstat (limited to 'nix/flake.nix')
-rw-r--r--nix/flake.nix10
1 files changed, 4 insertions, 6 deletions
diff --git a/nix/flake.nix b/nix/flake.nix
index bab8574..3c56a49 100644
--- a/nix/flake.nix
+++ b/nix/flake.nix
@@ -53,11 +53,6 @@
];
};
});
-
- pkgs = import nixpkgs {
- inherit system;
- overlays = [ nix-topology.overlays.default ];
- };
in {
nixosConfigurations = builtins.listToAttrs (mkConfigs [
"affinity"
@@ -67,7 +62,10 @@
]);
topology."${system}" = import nix-topology {
- inherit pkgs;
+ pkgs = import nixpkgs {
+ inherit system;
+ overlays = [ nix-topology.overlays.default ];
+ };
modules = [
./topology/default.nix
{ nixosConfigurations = self.nixosConfigurations; }