aboutsummaryrefslogtreecommitdiff
path: root/nix/flake.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-02-03 15:35:10 -0800
committerPreston Pan <ret2pop@gmail.com>2025-02-03 15:35:10 -0800
commit8e5d3a8fcd6893bcd4903cc9b7bfe96f6486d7c6 (patch)
tree6881c472ddbabd6f3788066485f78fe5ddae0b4d /nix/flake.nix
parentd6efefc1d9e6b9fd515c5cb5f2a077e05caeaab7 (diff)
Add spontaneity system; add port to firewall
Diffstat (limited to 'nix/flake.nix')
-rw-r--r--nix/flake.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/nix/flake.nix b/nix/flake.nix
index 058635a..50febed 100644
--- a/nix/flake.nix
+++ b/nix/flake.nix
@@ -75,7 +75,16 @@
spontaneity = nixpkgs.lib.nixosSystem {
system = "x86_64-linux";
specialArgs = attrs;
- modules = [];
+ modules = [
+ lanzaboote.nixosModules.lanzaboote
+ disko.nixosModules.disko
+ home-manager.nixosModules.home-manager
+ sops-nix.nixosModules.sops
+ { nixpkgs.overlays = [ nur.overlays.default ]; }
+ { home-manager.extraSpecialArgs = attrs; }
+ ./modules/vda-simple.nix
+ ./systems/spontaneity/default.nix
+ ];
};
};
};