aboutsummaryrefslogtreecommitdiff
path: root/nix/flake.nix
diff options
context:
space:
mode:
authorPreston Pan <ret2pop@gmail.com>2025-01-16 02:11:26 -0800
committerPreston Pan <ret2pop@gmail.com>2025-01-16 02:11:26 -0800
commit1a3486d77574c06b395ab6cda41084f5ed24a3f4 (patch)
tree69d1051bd14a0c3cb374f84a8c06cb655eba509b /nix/flake.nix
parent2dff9d2b61244fed49136028d0e0f6ae3ae759cf (diff)
modularized nix configuration; builds correctly
Diffstat (limited to 'nix/flake.nix')
-rw-r--r--nix/flake.nix11
1 files changed, 5 insertions, 6 deletions
diff --git a/nix/flake.nix b/nix/flake.nix
index 555a8c1..787b3a7 100644
--- a/nix/flake.nix
+++ b/nix/flake.nix
@@ -38,7 +38,7 @@
imports = [ (modulesPath + "/installer/cd-dvd/installation-cd-minimal.nix") ];
}
)
- ./systems/installer/iso.nix
+ ./systems/installer/default.nix
];
};
@@ -46,15 +46,14 @@
system = "x86_64-linux";
specialArgs = attrs;
modules = [
- { nixpkgs.overlays = [ nur.overlays.default ]; }
- { home-manager.extraSpecialArgs = attrs; }
lanzaboote.nixosModules.lanzaboote
disko.nixosModules.disko
home-manager.nixosModules.home-manager
sops-nix.nixosModules.sops
- ./systems/desktop/configuration.nix
- ./systems/desktop/sda-simple.nix
- ./systems/desktop/home.nix
+ { nixpkgs.overlays = [ nur.overlays.default ]; }
+ { home-manager.extraSpecialArgs = attrs; }
+
+ ./systems/continuity/default.nix
];
};