aboutsummaryrefslogtreecommitdiff
path: root/live/iso.nix
diff options
context:
space:
mode:
Diffstat (limited to 'live/iso.nix')
-rw-r--r--live/iso.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/live/iso.nix b/live/iso.nix
index 2a3bed7..ad6484c 100644
--- a/live/iso.nix
+++ b/live/iso.nix
@@ -138,12 +138,10 @@ if [ ! -d "$HOME/toughnix/" ]; then
fi
vim "$HOME/toughnix/desktop/vars.nix"
-DISK="$(gum --placeholder "Disk (ex: /dev/sda)")"
+DISK="$(gum input --placeholder "Disk (ex: /dev/sda)")"
-gum confirm --default=false \
- "🔥 🔥 🔥 WARNING!!!! This will ERASE ALL DATA on the disk $DISK. Are you sure you want to continue?"
-sudo nix run 'github:nix-community/disko/latest#disko-install' -- --write-efi-boot-entries --flake
- './toughnix#continuity-dell' --disk main "$DISK"
+gum confirm --default=false "🔥 🔥 🔥 WARNING!!!! This will ERASE ALL DATA on the disk $DISK. Are you sure you want to continue?"
+sudo nix run 'github:nix-community/disko/latest#disko-install' -- --write-efi-boot-entries --flake './toughnix#continuity-dell' --disk main "$DISK"
'')
];
};