aboutsummaryrefslogtreecommitdiff
path: root/disko/sda-simple.nix
diff options
context:
space:
mode:
Diffstat (limited to 'disko/sda-simple.nix')
-rw-r--r--disko/sda-simple.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/disko/sda-simple.nix b/disko/sda-simple.nix
new file mode 100644
index 0000000..7e275e5
--- /dev/null
+++ b/disko/sda-simple.nix
@@ -0,0 +1,39 @@
+{
+ disko.devices = {
+ disk = {
+ main = {
+ type = "disk";
+ device = "/dev/sda";
+ content = {
+ type = "gpt";
+ partitions = {
+ ESP = {
+ size = "500M";
+ type = "EF00";
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ mountOptions = [ "umask=0077" ];
+ };
+ };
+ luks = {
+ size = "100%";
+ content = {
+ type = "luks";
+ name = "crypted";
+ settings.allowDiscards = true;
+ passwordFile = "/tmp/secret.key";
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ };
+ };
+ };
+ };
+ };
+ };
+ };
+ };
+}