aboutsummaryrefslogtreecommitdiff
path: root/desktop/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/home.nix')
-rw-r--r--desktop/home.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/desktop/home.nix b/desktop/home.nix
index ed21c97..0143c00 100644
--- a/desktop/home.nix
+++ b/desktop/home.nix
@@ -13,9 +13,8 @@ in
if [ ! -d "${config.home.homeDirectory}/src/publish-org-roam-ui" ]; then
mkdir -p ${config.home.homeDirectory}/src
${pkgs.git}/bin/git clone https://git.nullring.xyz/publish-org-roam-ui.git ${config.home.homeDirectory}/src/publish-org-roam-ui
- ${pkgs.git}/bin/git clone https://git.nullring.xyz/toughnix.git ${config.home.homeDirectory}/src/toughnix
fi
-
+
if [ ! -d "${config.home.homeDirectory}/.password-store" ]; then
${pkgs.git}/bin/git clone ${vars.passwordRepo} ${config.home.homeDirectory}/.password-store
fi
@@ -1021,8 +1020,8 @@ on-notify=exec mpv /home/${vars.userName}/sounds/notification.wav --no-config --
g = "git";
v = "vim";
py = "python3";
- rb = "doas nixos-rebuild switch --flake .#continuity-dell";
- nfu = "cd ~/src/toughnix && git add . && git commit -m \"new flake lock\" && cd /etc/nixos/ && doas nix flake update";
+ rb = "sudo nixos-rebuild switch --flake .#continuity";
+ nfu = "cd ~/src/toughnix && git add . && git commit -m \"new flake lock\" && nix flake update";
usite
= "cd ~/src/publish-org-roam-ui && bash local.sh && rm -rf ~/website_html/graph_view; cp -r ~/src/publish-org-roam-ui/out ~/website_html/graph_view && rsync -azvP --chmod=\"Du=rwx,Dg=rx,Do=rx,Fu=rw,Fg=r,Fo=r\" ~/website_html/ ${vars.websiteLocation}";
sai = "eval \"$(ssh-agent -s)\" && ssh-add ~/.ssh/id_ed25519 && ssh-add -l";