aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/vda-simple.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/vda-simple.nix')
-rw-r--r--nix/modules/vda-simple.nix16
1 files changed, 4 insertions, 12 deletions
diff --git a/nix/modules/vda-simple.nix b/nix/modules/vda-simple.nix
index f18b1c3..32fa28d 100644
--- a/nix/modules/vda-simple.nix
+++ b/nix/modules/vda-simple.nix
@@ -1,26 +1,18 @@
{
disko.devices = {
disk = {
- my-disk = {
+ main = {
device = "/dev/vda";
type = "disk";
content = {
type = "gpt";
partitions = {
- ESP = {
- type = "EF00";
- size = "500M";
- priority = 1;
- content = {
- type = "filesystem";
- format = "vfat";
- mountpoint = "/boot";
- mountOptions = [ "umask=0077" ];
- };
+ boot = {
+ size = "1M";
+ type = "EF02";
};
root = {
size = "100%";
- priority = 2;
content = {
type = "filesystem";
format = "ext4";