aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/ssh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/ssh.nix')
-rw-r--r--nix/modules/ssh.nix14
1 files changed, 8 insertions, 6 deletions
diff --git a/nix/modules/ssh.nix b/nix/modules/ssh.nix
index 6083393..55dc2fb 100644
--- a/nix/modules/ssh.nix
+++ b/nix/modules/ssh.nix
@@ -1,10 +1,12 @@
{ config, ... }:
{
- enable = true;
- settings = {
- PasswordAuthentication = true;
- AllowUsers = [ config.vars.userName ];
- PermitRootLogin = "no";
- KbdInteractiveAuthentication = false;
+ services.openssh = {
+ enable = true;
+ settings = {
+ PasswordAuthentication = true;
+ AllowUsers = [ config.monorepo.vars.userName ];
+ PermitRootLogin = "no";
+ KbdInteractiveAuthentication = false;
+ };
};
}