aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/secure-boot.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/secure-boot.nix')
-rw-r--r--nix/modules/secure-boot.nix20
1 files changed, 0 insertions, 20 deletions
diff --git a/nix/modules/secure-boot.nix b/nix/modules/secure-boot.nix
deleted file mode 100644
index 0785835..0000000
--- a/nix/modules/secure-boot.nix
+++ /dev/null
@@ -1,20 +0,0 @@
-{ pkgs, lib, config, inputs, ... }:
-{
- imports = [
- inputs.lanzaboote.nixosModules.lanzaboote
- ];
-
- options = {
- secure-boot.enable = lib.mkEnableOption "Enables secure boot on system";
- };
-
- config = lib.mkIf config.secure-boot.enable {
- boot = {
- loader.systemd-boot.enable = lib.mkForce false;
- lanzaboote = {
- enable = true;
- pkiBundle = "/etc/secureboot";
- };
- };
- };
-}