aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/home/yt-dlp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/home/yt-dlp.nix')
-rw-r--r--nix/modules/home/yt-dlp.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/nix/modules/home/yt-dlp.nix b/nix/modules/home/yt-dlp.nix
index 729fb8f..5ed35f5 100644
--- a/nix/modules/home/yt-dlp.nix
+++ b/nix/modules/home/yt-dlp.nix
@@ -1,11 +1,13 @@
{ lib, config, ... }:
{
- enable = lib.mkDefault config.monorepo.profiles.home.video.enable;
- settings = {
- embed-thumbnail = true;
- embed-subs = true;
- sub-langs = "all";
- downloader = "aria2c";
- downloader-args = "aria2c:'-c -x8 -s8 -k1M'";
+ programs.yt-dlp = {
+ enable = true;
+ settings = {
+ embed-thumbnail = true;
+ embed-subs = true;
+ sub-langs = "all";
+ downloader = "aria2c";
+ downloader-args = "aria2c:'-c -x8 -s8 -k1M'";
+ };
};
}