aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/home/waybar.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/home/waybar.nix')
-rw-r--r--nix/modules/home/waybar.nix36
1 files changed, 19 insertions, 17 deletions
diff --git a/nix/modules/home/waybar.nix b/nix/modules/home/waybar.nix
index 3ef81e8..8e797a5 100644
--- a/nix/modules/home/waybar.nix
+++ b/nix/modules/home/waybar.nix
@@ -1,7 +1,8 @@
{ lib, config, ... }:
{
- enable = lib.mkDefault config.monorepo.profiles.hyprland.enable;
- style = ''
+ programs.waybar = {
+ enable = lib.mkDefault config.monorepo.profiles.hyprland.enable;
+ style = ''
* {
border: none;
border-radius: 0px;
@@ -247,25 +248,26 @@
font-weight: bold;
}
'';
- settings = {
- mainBar = {
- layer = "top";
- position = "top";
- height = 50;
+ settings = {
+ mainBar = {
+ layer = "top";
+ position = "top";
+ height = 50;
- output = config.vars.monitors;
+ output = config.monorepo.vars.monitors;
- modules-left = [ "hyprland/workspaces" ];
- modules-center = [ "hyprland/window" ];
- modules-right = [ "battery" "clock" ];
+ modules-left = [ "hyprland/workspaces" ];
+ modules-center = [ "hyprland/window" ];
+ modules-right = [ "battery" "clock" ];
- battery = {
- format = "{icon} {capacity}%";
- format-icons = ["" "" "" "" "" ];
- };
+ battery = {
+ format = "{icon} {capacity}%";
+ format-icons = ["" "" "" "" "" ];
+ };
- clock = {
- format = "⏰ {:%a %d, %b %H:%M}";
+ clock = {
+ format = "⏰ {:%a %d, %b %H:%M}";
+ };
};
};
};