aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/home/secrets.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/home/secrets.nix')
-rw-r--r--nix/modules/home/secrets.nix29
1 files changed, 14 insertions, 15 deletions
diff --git a/nix/modules/home/secrets.nix b/nix/modules/home/secrets.nix
index 64eab73..d24129c 100644
--- a/nix/modules/home/secrets.nix
+++ b/nix/modules/home/secrets.nix
@@ -1,19 +1,18 @@
-{ lib, config, pkgs, inputs, ... }:
+{ config, ... }:
{
- imports = [
- ../vars.nix
- ];
-
- options = {
- secrets.enable = lib.mkEnableOption "enables encrypted secrets on system";
+ defaultSopsFile = ../../secrets/secrets.yaml;
+ age = {
+ keyFile = "/home/${config.vars.userName}/.ssh/keys.txt";
};
-
- config = lib.mkIf config.secrets.enable {
- home-manager = {
- sharedModules = [
- inputs.sops-nix.homeManagerModules.sops
- ];
- users."${user.user}" = {};
- };
+ secrets.mail = {
+ format = "yaml";
+ path = "${config.sops.defaultSymlinkPath}/mail";
};
+ secrets.digikey = {
+ format = "yaml";
+ path = "${config.sops.defaultSymlinkPath}/digikey";
+ };
+
+ defaultSymlinkPath = "/run/user/1000/secrets";
+ defaultSecretsMountPoint = "/run/user/1000/secrets.d";
}