aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/home/home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/home/home.nix')
-rw-r--r--nix/modules/home/home.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/nix/modules/home/home.nix b/nix/modules/home/home.nix
new file mode 100644
index 0000000..d82445a
--- /dev/null
+++ b/nix/modules/home/home.nix
@@ -0,0 +1,15 @@
+{ config, sops-nix, ... }:
+{
+ imports = [
+ ../default.nix
+ ];
+
+ home-manager = {
+ sharedModules = [
+ sops-nix.homeManagerModules.sops
+ ];
+ useGlobalPkgs = true;
+ useUserPackages = true;
+ users."${config.monorepo.vars.userName}" = import ./user.nix;
+ };
+}