aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/home/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/home/git.nix')
-rw-r--r--nix/modules/home/git.nix34
1 files changed, 18 insertions, 16 deletions
diff --git a/nix/modules/home/git.nix b/nix/modules/home/git.nix
index 84f3b0f..d019ddb 100644
--- a/nix/modules/home/git.nix
+++ b/nix/modules/home/git.nix
@@ -1,22 +1,24 @@
{ lib, config, ... }:
{
- enable = lib.mkDefault config.monorepo.profiles.home.enable;
- userName = config.vars.fullName;
- userEmail = config.vars.email;
- signing = {
- key = config.vars.gpgKey;
- signByDefault = true;
- };
+ programs.git = {
+ enable = true;
+ userName = config.monorepo.vars.fullName;
+ userEmail = config.monorepo.profiles.email.email;
+ signing = {
+ key = config.monorepo.vars.gpgKey;
+ signByDefault = true;
+ };
- extraConfig = {
- init.defaultBranch = "main";
- };
+ extraConfig = {
+ init.defaultBranch = "main";
+ };
- aliases = {
- co = "checkout";
- c = "commit";
- a = "add";
- s = "switch";
- b = "branch";
+ aliases = {
+ co = "checkout";
+ c = "commit";
+ a = "add";
+ s = "switch";
+ b = "branch";
+ };
};
}