aboutsummaryrefslogtreecommitdiff
path: root/nix/modules/cuda.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/modules/cuda.nix')
-rw-r--r--nix/modules/cuda.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/nix/modules/cuda.nix b/nix/modules/cuda.nix
new file mode 100644
index 0000000..0c90278
--- /dev/null
+++ b/nix/modules/cuda.nix
@@ -0,0 +1,9 @@
+{ config, lib, pkgs, ... }:
+{
+ environment.systemPackages = with pkgs; [
+ cudatoolkit
+ cudaPackages.cudnn
+ cudaPackages.libcublas
+ linuxPackages.nvidia_x11
+ ];
+}